CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-3470

The ssl3_send_client_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h, when an anonymous ECDH cipher suite is used, allows remote attackers to cause a denial of service (NULL pointer dereference and client crash) by triggering a NULL certificate value.
Publish Date : 2014-06-05 Last Update Date : 2014-09-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
AIX OpenSSL Anonymous ECDH denial of service oval:org.mitre.oval:def:24780 unix
DSA-2950-1 openssl - security update oval:org.mitre.oval:def:24711 unix
ELSA-2014:0625: openssl security update (Important) oval:org.mitre.oval:def:25171 unix
Remote Code Execution or Unauthorized Accesss oval:org.mitre.oval:def:25085 unix
RHSA-2014:0625: openssl security update (Important) oval:org.mitre.oval:def:24892 unix
RHSA-2014:0625: openssl security update (Important) oval:com.redhat.rhsa:def:20140625 unix
RHSA-2014:0679: openssl security update (Important) oval:com.redhat.rhsa:def:20140679 unix
USN-2232-1 -- openssl vulnerabilities oval:org.mitre.oval:def:24448 unix
USN-2232-2 -- openssl regression oval:org.mitre.oval:def:25082 unix
USN-2232-3 -- openssl regression oval:org.mitre.oval:def:24628 unix
Vulnerability in OpenSSL 0.9.8 — 0.9.8za, 1.0.0 — 1.0.0m and 1.0.1 — 1.0.1h, allows man-in-the-middle attackers to... oval:org.mitre.oval:def:25039 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2014-3470

# Product Type Vendor Product Version Update Edition Language
1 OS Fedoraproject Fedora Version Details Vulnerabilities
2 Application Openssl Openssl 0.9.8y Version Details Vulnerabilities
3 Application Openssl Openssl 0.9.8j Version Details Vulnerabilities
4 Application Openssl Openssl 0.9.8t Version Details Vulnerabilities
5 Application Openssl Openssl 0.9.8e Version Details Vulnerabilities
6 Application Openssl Openssl 0.9.8o Version Details Vulnerabilities
7 Application Openssl Openssl 0.9.8 Version Details Vulnerabilities
8 Application Openssl Openssl 0.9.8k Version Details Vulnerabilities
9 Application Openssl Openssl 0.9.8u Version Details Vulnerabilities
10 Application Openssl Openssl 0.9.8f Version Details Vulnerabilities
11 Application Openssl Openssl 0.9.8p Version Details Vulnerabilities
12 Application Openssl Openssl 0.9.8a Version Details Vulnerabilities
13 Application Openssl Openssl 0.9.8l Version Details Vulnerabilities
14 Application Openssl Openssl 0.9.8v Version Details Vulnerabilities
15 Application Openssl Openssl 0.9.8g Version Details Vulnerabilities
16 Application Openssl Openssl 0.9.8q Version Details Vulnerabilities
17 Application Openssl Openssl 0.9.8b Version Details Vulnerabilities
18 Application Openssl Openssl 0.9.8m Version Details Vulnerabilities
19 Application Openssl Openssl 0.9.8w Version Details Vulnerabilities
20 Application Openssl Openssl 0.9.8h Version Details Vulnerabilities
21 Application Openssl Openssl 0.9.8r Version Details Vulnerabilities
22 Application Openssl Openssl 0.9.8c Version Details Vulnerabilities
23 Application Openssl Openssl 0.9.8m Beta1 Version Details Vulnerabilities
24 Application Openssl Openssl 0.9.8x Version Details Vulnerabilities
25 Application Openssl Openssl 0.9.8i Version Details Vulnerabilities
26 Application Openssl Openssl 0.9.8s Version Details Vulnerabilities
27 Application Openssl Openssl 0.9.8d Version Details Vulnerabilities
28 Application Openssl Openssl 0.9.8n Version Details Vulnerabilities
29 Application Openssl Openssl 1.0.0g Version Details Vulnerabilities
30 Application Openssl Openssl 1.0.0b Version Details Vulnerabilities
31 Application Openssl Openssl 1.0.0 Beta2 Version Details Vulnerabilities
32 Application Openssl Openssl 1.0.0h Version Details Vulnerabilities
33 Application Openssl Openssl 1.0.0c Version Details Vulnerabilities
34 Application Openssl Openssl 1.0.0 Beta3 Version Details Vulnerabilities
35 Application Openssl Openssl 1.0.0i Version Details Vulnerabilities
36 Application Openssl Openssl 1.0.0d Version Details Vulnerabilities
37 Application Openssl Openssl 1.0.0 Beta4 Version Details Vulnerabilities
38 Application Openssl Openssl 1.0.0j Version Details Vulnerabilities
39 Application Openssl Openssl 1.0.0e Version Details Vulnerabilities
40 Application Openssl Openssl 1.0.0 Beta5 Version Details Vulnerabilities
41 Application Openssl Openssl 1.0.0k Version Details Vulnerabilities
42 Application Openssl Openssl 1.0.0 Version Details Vulnerabilities
43 Application Openssl Openssl 1.0.0f Version Details Vulnerabilities
44 Application Openssl Openssl 1.0.0a Version Details Vulnerabilities
45 Application Openssl Openssl 1.0.0l Version Details Vulnerabilities
46 Application Openssl Openssl 1.0.0 Beta1 Version Details Vulnerabilities
47 Application Openssl Openssl 1.0.1c Version Details Vulnerabilities
48 Application Openssl Openssl 1.0.1 Beta1 Version Details Vulnerabilities
49 Application Openssl Openssl 1.0.1d Version Details Vulnerabilities
50 Application Openssl Openssl 1.0.1 Beta2 Version Details Vulnerabilities
51 Application Openssl Openssl 1.0.1e Version Details Vulnerabilities
52 Application Openssl Openssl 1.0.1 Beta3 Version Details Vulnerabilities
53 Application Openssl Openssl 1.0.1f Version Details Vulnerabilities
54 Application Openssl Openssl 1.0.1a Version Details Vulnerabilities
55 Application Openssl Openssl 1.0.1g Version Details Vulnerabilities
56 Application Openssl Openssl 1.0.1b Version Details Vulnerabilities
57 Application Openssl Openssl 1.0.1 Version Details Vulnerabilities
58 OS Redhat Enterprise Linux 5 Version Details Vulnerabilities
59 OS Redhat Enterprise Linux 6 Version Details Vulnerabilities
60 Application Redhat Storage 2.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Fedoraproject Fedora 1
Openssl Openssl 56
Redhat Enterprise Linux 2
Redhat Storage 1

- References For CVE-2014-3470

http://secunia.com/advisories/58939
SECUNIA 58939
http://secunia.com/advisories/58797
SECUNIA 58797
http://secunia.com/advisories/59191
SECUNIA 59191
http://secunia.com/advisories/59162
SECUNIA 59162
http://secunia.com/advisories/58579
SECUNIA 58579
http://secunia.com/advisories/59120
SECUNIA 59120
http://secunia.com/advisories/59126
SECUNIA 59126
http://secunia.com/advisories/59300
SECUNIA 59300
http://secunia.com/advisories/59301
SECUNIA 59301
http://secunia.com/advisories/59342
SECUNIA 59342
http://secunia.com/advisories/59413
SECUNIA 59413
http://secunia.com/advisories/59442
SECUNIA 59442
http://secunia.com/advisories/59438
SECUNIA 59438
http://secunia.com/advisories/59451
SECUNIA 59451
http://secunia.com/advisories/59450
SECUNIA 59450
http://secunia.com/advisories/59459
SECUNIA 59459
http://secunia.com/advisories/59490
SECUNIA 59490
http://secunia.com/advisories/59491
SECUNIA 59491
http://secunia.com/advisories/59895
SECUNIA 59895
http://secunia.com/advisories/59784
SECUNIA 59784
http://secunia.com/advisories/59721
SECUNIA 59721
http://secunia.com/advisories/59669
SECUNIA 59669
http://secunia.com/advisories/59666
SECUNIA 59666
http://secunia.com/advisories/59659
SECUNIA 59659
http://secunia.com/advisories/59655
SECUNIA 59655
http://secunia.com/advisories/59514
SECUNIA 59514
http://secunia.com/advisories/59495
SECUNIA 59495
http://secunia.com/advisories/60571
SECUNIA 60571
http://secunia.com/advisories/59916
SECUNIA 59916
http://secunia.com/advisories/59990
SECUNIA 59990
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140605-openssl
CISCO 20140605 Multiple Vulnerabilities in OpenSSL Affecting Cisco Products
http://www-01.ibm.com/support/docview.wss?uid=isg400001841 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=isg400001843 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21673137 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21676035 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21676062 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21676419 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21676496 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21676655 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21677527 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21677695 CONFIRM
http://www.blackberry.com/btsc/KB36051 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg24037761 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21678289 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21678167 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21677828 CONFIRM
http://www14.software.ibm.com/webapp/set2/subscriptions/pqvcmjd?mode=18&ID=6061&myns=phmc&mync=E CONFIRM
http://www.novell.com/support/kb/doc.php?id=7015264 CONFIRM
http://www.huawei.com/en/security/psirt/security-bulletins/security-advisories/hw-345106.htm CONFIRM
http://www.openssl.org/news/secadv_20140605.txt CONFIRM
http://www.novell.com/support/kb/doc.php?id=7015300 CONFIRM
http://www.splunk.com/view/SP-CAAAM2D CONFIRM
http://www.securityfocus.com/bid/67898
BID 67898 OpenSSL CVE-2014-3470 Denial of Service Vulnerability Release Date:2014-09-21
http://www.oracle.com/technetwork/topics/security/cpujul2014-1972956.html CONFIRM
http://www14.software.ibm.com/webapp/set2/subscriptions/pqvcmjd?mode=18&ID=6060&myns=phmc&mync=E CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=1103600 CONFIRM
https://kc.mcafee.com/corporate/index?page=content&id=SB10075 CONFIRM
https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=8011cd56e39a433b1837465259a9bd24a38727fb CONFIRM
https://kb.bluecoat.com/index?page=content&id=SA80 CONFIRM

- Metasploit Modules Related To CVE-2014-3470

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.