CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2013-4287

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.
Publish Date : 2013-10-17 Last Update Date : 2014-03-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 310

- Related OVAL Definitions

Title Definition Id Class Family
ELSA-2013:1441: rubygems security update (Moderate) oval:org.mitre.oval:def:23772 unix
RHSA-2013:1441: rubygems security update (Moderate) oval:org.mitre.oval:def:20861 unix
RHSA-2013:1441: rubygems security update (Moderate) oval:com.redhat.rhsa:def:20131441 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2013-4287

# Product Type Vendor Product Version Update Edition Language
1 OS Redhat Enterprise Linux 6 Version Details Vulnerabilities
2 Application Ruby-lang Ruby 1.9 Version Details Vulnerabilities
3 Application Ruby-lang Ruby 1.9.1 Version Details Vulnerabilities
4 Application Ruby-lang Ruby 1.9.2 Version Details Vulnerabilities
5 Application Ruby-lang Ruby 1.9.3 P392 Version Details Vulnerabilities
6 Application Ruby-lang Ruby 1.9.3 P125 Version Details Vulnerabilities
7 Application Ruby-lang Ruby 1.9.3 P426 Version Details Vulnerabilities
8 Application Ruby-lang Ruby 1.9.3 P194 Version Details Vulnerabilities
9 Application Ruby-lang Ruby 1.9.3 P429 Version Details Vulnerabilities
10 Application Ruby-lang Ruby 1.9.3 P286 Version Details Vulnerabilities
11 Application Ruby-lang Ruby 1.9.3 P383 Version Details Vulnerabilities
12 Application Ruby-lang Ruby 1.9.3 Version Details Vulnerabilities
13 Application Ruby-lang Ruby 1.9.3 P385 Version Details Vulnerabilities
14 Application Ruby-lang Ruby 1.9.3 P0 Version Details Vulnerabilities
15 Application Ruby-lang Ruby 2.0 Version Details Vulnerabilities
16 Application Ruby-lang Ruby 2.0.0 RC2 Version Details Vulnerabilities
17 Application Ruby-lang Ruby 2.0.0 P195 Version Details Vulnerabilities
18 Application Ruby-lang Ruby 2.0.0 P247 Version Details Vulnerabilities
19 Application Ruby-lang Ruby 2.0.0 Preview1 Version Details Vulnerabilities
20 Application Ruby-lang Ruby 2.0.0 Preview2 Version Details Vulnerabilities
21 Application Ruby-lang Ruby 2.0.0 Version Details Vulnerabilities
22 Application Ruby-lang Ruby 2.0.0 RC1 Version Details Vulnerabilities
23 Application Ruby-lang Ruby 2.0.0 P0 Version Details Vulnerabilities
24 Application Rubygems Rubygems 1.8.0 Version Details Vulnerabilities
25 Application Rubygems Rubygems 1.8.1 Version Details Vulnerabilities
26 Application Rubygems Rubygems 1.8.2 Version Details Vulnerabilities
27 Application Rubygems Rubygems 1.8.3 Version Details Vulnerabilities
28 Application Rubygems Rubygems 1.8.4 Version Details Vulnerabilities
29 Application Rubygems Rubygems 1.8.5 Version Details Vulnerabilities
30 Application Rubygems Rubygems 1.8.6 Version Details Vulnerabilities
31 Application Rubygems Rubygems 1.8.7 Version Details Vulnerabilities
32 Application Rubygems Rubygems 1.8.8 Version Details Vulnerabilities
33 Application Rubygems Rubygems 1.8.9 Version Details Vulnerabilities
34 Application Rubygems Rubygems 1.8.10 Version Details Vulnerabilities
35 Application Rubygems Rubygems 1.8.11 Version Details Vulnerabilities
36 Application Rubygems Rubygems 1.8.12 Version Details Vulnerabilities
37 Application Rubygems Rubygems 1.8.13 Version Details Vulnerabilities
38 Application Rubygems Rubygems 1.8.14 Version Details Vulnerabilities
39 Application Rubygems Rubygems 1.8.15 Version Details Vulnerabilities
40 Application Rubygems Rubygems 1.8.16 Version Details Vulnerabilities
41 Application Rubygems Rubygems 1.8.17 Version Details Vulnerabilities
42 Application Rubygems Rubygems 1.8.18 Version Details Vulnerabilities
43 Application Rubygems Rubygems 1.8.19 Version Details Vulnerabilities
44 Application Rubygems Rubygems 1.8.20 Version Details Vulnerabilities
45 Application Rubygems Rubygems 1.8.21 Version Details Vulnerabilities
46 Application Rubygems Rubygems 1.8.22 Version Details Vulnerabilities
47 Application Rubygems Rubygems 1.8.23 Version Details Vulnerabilities
48 Application Rubygems Rubygems 1.8.24 Version Details Vulnerabilities
49 Application Rubygems Rubygems 1.8.25 Version Details Vulnerabilities
50 Application Rubygems Rubygems 2.0.0 Version Details Vulnerabilities
51 Application Rubygems Rubygems 2.0.1 Version Details Vulnerabilities
52 Application Rubygems Rubygems 2.0.2 Version Details Vulnerabilities
53 Application Rubygems Rubygems 2.0.3 Version Details Vulnerabilities
54 Application Rubygems Rubygems 2.0.4 Version Details Vulnerabilities
55 Application Rubygems Rubygems 2.0.5 Version Details Vulnerabilities
56 Application Rubygems Rubygems 2.0.6 Version Details Vulnerabilities
57 Application Rubygems Rubygems 2.0.7 Version Details Vulnerabilities
58 Application Rubygems Rubygems 2.1.0 RC1 Version Details Vulnerabilities
59 Application Rubygems Rubygems 2.1.0 RC2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Redhat Enterprise Linux 1
Ruby-lang Ruby 22
Rubygems Rubygems 36

- References For CVE-2013-4287

http://rhn.redhat.com/errata/RHSA-2013-1427.html
REDHAT RHSA-2013:1427
http://rhn.redhat.com/errata/RHSA-2013-1852.html
REDHAT RHSA-2013:1852
http://blog.rubygems.org/2013/09/09/CVE-2013-4287.html CONFIRM
http://www.openwall.com/lists/oss-security/2013/09/10/1
MLIST [oss-security] 20130909 CVE-2013-4287 Algorithmic complexity vulnerability in RubyGems 2.0.7 and older
http://rhn.redhat.com/errata/RHSA-2013-1441.html
REDHAT RHSA-2013:1441
http://rhn.redhat.com/errata/RHSA-2013-1523.html
REDHAT RHSA-2013:1523
http://rhn.redhat.com/errata/RHSA-2014-0207.html
REDHAT RHSA-2014:0207
http://secunia.com/advisories/55381
SECUNIA 55381

- Metasploit Modules Related To CVE-2013-4287

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.