CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-1455

The DOCSIS dissector in Wireshark 0.9.6 through 1.0.12 and 1.2.0 through 1.2.7 allows user-assisted remote attackers to cause a denial of service (application crash) via a malformed packet trace file.
Publish Date : 2010-05-12 Last Update Date : 2011-02-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 20

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
1.8
AV:A/AC:H/Au:N/C:N/I:N/A:P 2010-05-05 2010-05-05
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2010-1455 oval:org.opensuse.security:def:20101455 unix
ELSA-2010:0625: wireshark security update (Moderate) oval:org.mitre.oval:def:23018 unix
RHSA-2010:0625: wireshark security update (Moderate) oval:org.mitre.oval:def:22021 unix
RHSA-2010:0625: wireshark security update (Moderate) oval:com.redhat.rhsa:def:20100625 unix
Wireshark DoS Vulnerability due to DOCSIS dissector oval:org.mitre.oval:def:7331 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-1455

# Product Type Vendor Product Version Update Edition Language
1 Application Ethereal Group Ethereal 0.9.6 Version Details Vulnerabilities
2 Application Ethereal Group Ethereal 0.9.7 Version Details Vulnerabilities
3 Application Ethereal Group Ethereal 0.9.8 Version Details Vulnerabilities
4 Application Ethereal Group Ethereal 0.99.0 Version Details Vulnerabilities
5 Application Wireshark Wireshark 0.9.6 Version Details Vulnerabilities
6 Application Wireshark Wireshark 0.99.0 Version Details Vulnerabilities
7 Application Wireshark Wireshark 0.99.1 Version Details Vulnerabilities
8 Application Wireshark Wireshark 0.99.2 Version Details Vulnerabilities
9 Application Wireshark Wireshark 0.99.3 Version Details Vulnerabilities
10 Application Wireshark Wireshark 0.99.4 Version Details Vulnerabilities
11 Application Wireshark Wireshark 0.99.5 Version Details Vulnerabilities
12 Application Wireshark Wireshark 0.99.6 Version Details Vulnerabilities
13 Application Wireshark Wireshark 0.99.7 Version Details Vulnerabilities
14 Application Wireshark Wireshark 0.99.8 Version Details Vulnerabilities
15 Application Wireshark Wireshark 1.0.0 Version Details Vulnerabilities
16 Application Wireshark Wireshark 1.0.1 Version Details Vulnerabilities
17 Application Wireshark Wireshark 1.0.2 Version Details Vulnerabilities
18 Application Wireshark Wireshark 1.0.3 Version Details Vulnerabilities
19 Application Wireshark Wireshark 1.0.4 Version Details Vulnerabilities
20 Application Wireshark Wireshark 1.0.5 Version Details Vulnerabilities
21 Application Wireshark Wireshark 1.0.6 Version Details Vulnerabilities
22 Application Wireshark Wireshark 1.0.7 Version Details Vulnerabilities
23 Application Wireshark Wireshark 1.0.8 Version Details Vulnerabilities
24 Application Wireshark Wireshark 1.0.9 Version Details Vulnerabilities
25 Application Wireshark Wireshark 1.0.10 Version Details Vulnerabilities
26 Application Wireshark Wireshark 1.0.11 Version Details Vulnerabilities
27 Application Wireshark Wireshark 1.0.12 Version Details Vulnerabilities
28 Application Wireshark Wireshark 1.2.0 Version Details Vulnerabilities
29 Application Wireshark Wireshark 1.2.1 Version Details Vulnerabilities
30 Application Wireshark Wireshark 1.2.2 Version Details Vulnerabilities
31 Application Wireshark Wireshark 1.2.3 Version Details Vulnerabilities
32 Application Wireshark Wireshark 1.2.4 Version Details Vulnerabilities
33 Application Wireshark Wireshark 1.2.5 Version Details Vulnerabilities
34 Application Wireshark Wireshark 1.2.6 Version Details Vulnerabilities
35 Application Wireshark Wireshark 1.2.7 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ethereal Group Ethereal 4
Wireshark Wireshark 31

- References For CVE-2010-1455

http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
SUSE SUSE-SR:2011:002
http://www.mandriva.com/security/advisories?name=MDVSA-2010:099
MANDRIVA MDVSA-2010:099
http://secunia.com/advisories/39661
SECUNIA 39661
http://secunia.com/advisories/42877
SECUNIA 42877
http://xforce.iss.net/xforce/xfdb/58362
XF wireshark-docsis-dos(58362)
http://www.wireshark.org/security/wnpa-sec-2010-04.html CONFIRM
http://www.vupen.com/english/advisories/2011/0212
VUPEN ADV-2011-0212
http://www.vupen.com/english/advisories/2011/0076
VUPEN ADV-2011-0076
http://www.securityfocus.com/bid/39950
BID 39950 Wireshark DOCSIS Dissector Denial of Service Vulnerability Release Date:2010-09-08
http://www.wireshark.org/security/wnpa-sec-2010-03.html CONFIRM
http://www.osvdb.org/64363
OSVDB 64363
http://secunia.com/advisories/43068
SECUNIA 43068
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4644 CONFIRM
http://www.openwall.com/lists/oss-security/2010/05/07/7
MLIST [oss-security] 20100507 Re: CVE Assignment (wireshark)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4646 CONFIRM
http://www.vupen.com/english/advisories/2010/1081
VUPEN ADV-2010-1081
http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00003.html
SUSE SUSE-SR:2011:001

- Metasploit Modules Related To CVE-2010-1455

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.