CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-1949

The _gnutls_recv_client_kx_message function in lib/gnutls_kx.c in libgnutls in gnutls-serv in GnuTLS before 2.2.4 continues to process Client Hello messages within a TLS message after one has already been processed, which allows remote attackers to cause a denial of service (NULL dereference and crash) via a TLS message containing multiple Client Hello messages, aka GNUTLS-SA-2008-1-2.
Publish Date : 2008-05-21 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Denial Of Service
CWE ID 287

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2008-05-19 2008-05-19
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-1949 oval:org.opensuse.security:def:20081949 unix
DSA-1581 gnutls13 -- several vulnerabilities oval:org.mitre.oval:def:7887 unix
DSA-1581-1 gnutls13 - potential code execution oval:org.mitre.oval:def:19997 unix
ELSA-2008:0489: gnutls security update (Critical) oval:org.mitre.oval:def:22264 unix
RHSA-2008:0489: gnutls security update (Critical) oval:com.redhat.rhsa:def:20080489 unix
RHSA-2008:0492: gnutls security update (Important) oval:com.redhat.rhsa:def:20080492 unix
The _gnutls_recv_client_kx_message function in lib/gnutls_kx.c in libgnutls in gnutls-serv in GnuTLS before 2.2.4 contin... oval:org.mitre.oval:def:9519 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-1949

# Product Type Vendor Product Version Update Edition Language
1 Application GNU Gnutls 1.0.18 Version Details Vulnerabilities
2 Application GNU Gnutls 1.0.19 Version Details Vulnerabilities
3 Application GNU Gnutls 1.0.20 Version Details Vulnerabilities
4 Application GNU Gnutls 1.0.21 Version Details Vulnerabilities
5 Application GNU Gnutls 1.0.22 Version Details Vulnerabilities
6 Application GNU Gnutls 1.0.23 Version Details Vulnerabilities
7 Application GNU Gnutls 1.0.24 Version Details Vulnerabilities
8 Application GNU Gnutls 1.0.25 Version Details Vulnerabilities
9 Application GNU Gnutls 1.1.13 Version Details Vulnerabilities
10 Application GNU Gnutls 1.1.14 Version Details Vulnerabilities
11 Application GNU Gnutls 1.1.15 Version Details Vulnerabilities
12 Application GNU Gnutls 1.1.16 Version Details Vulnerabilities
13 Application GNU Gnutls 1.1.17 Version Details Vulnerabilities
14 Application GNU Gnutls 1.1.18 Version Details Vulnerabilities
15 Application GNU Gnutls 1.1.19 Version Details Vulnerabilities
16 Application GNU Gnutls 1.1.20 Version Details Vulnerabilities
17 Application GNU Gnutls 1.1.21 Version Details Vulnerabilities
18 Application GNU Gnutls 1.1.22 Version Details Vulnerabilities
19 Application GNU Gnutls 1.1.23 Version Details Vulnerabilities
20 Application GNU Gnutls 1.2.0 Version Details Vulnerabilities
21 Application GNU Gnutls 1.2.1 Version Details Vulnerabilities
22 Application GNU Gnutls 1.2.2 Version Details Vulnerabilities
23 Application GNU Gnutls 1.2.3 Version Details Vulnerabilities
24 Application GNU Gnutls 1.2.4 Version Details Vulnerabilities
25 Application GNU Gnutls 1.2.5 Version Details Vulnerabilities
26 Application GNU Gnutls 1.2.6 Version Details Vulnerabilities
27 Application GNU Gnutls 1.2.7 Version Details Vulnerabilities
28 Application GNU Gnutls 1.2.8 Version Details Vulnerabilities
29 Application GNU Gnutls 1.2.9 Version Details Vulnerabilities
30 Application GNU Gnutls 1.2.10 Version Details Vulnerabilities
31 Application GNU Gnutls 1.2.11 Version Details Vulnerabilities
32 Application GNU Gnutls 1.3.0 Version Details Vulnerabilities
33 Application GNU Gnutls 1.3.1 Version Details Vulnerabilities
34 Application GNU Gnutls 1.3.2 Version Details Vulnerabilities
35 Application GNU Gnutls 1.3.3 Version Details Vulnerabilities
36 Application GNU Gnutls 1.3.4 Version Details Vulnerabilities
37 Application GNU Gnutls 1.3.5 Version Details Vulnerabilities
38 Application GNU Gnutls 1.4.0 Version Details Vulnerabilities
39 Application GNU Gnutls 1.4.1 Version Details Vulnerabilities
40 Application GNU Gnutls 1.4.2 Version Details Vulnerabilities
41 Application GNU Gnutls 1.4.3 Version Details Vulnerabilities
42 Application GNU Gnutls 1.4.4 Version Details Vulnerabilities
43 Application GNU Gnutls 1.4.5 Version Details Vulnerabilities
44 Application GNU Gnutls 1.5.0 Version Details Vulnerabilities
45 Application GNU Gnutls 1.5.1 Version Details Vulnerabilities
46 Application GNU Gnutls 1.5.2 Version Details Vulnerabilities
47 Application GNU Gnutls 1.5.3 Version Details Vulnerabilities
48 Application GNU Gnutls 1.5.4 Version Details Vulnerabilities
49 Application GNU Gnutls 1.5.5 Version Details Vulnerabilities
50 Application GNU Gnutls 1.6.0 Version Details Vulnerabilities
51 Application GNU Gnutls 1.6.1 Version Details Vulnerabilities
52 Application GNU Gnutls 1.6.2 Version Details Vulnerabilities
53 Application GNU Gnutls 1.6.3 Version Details Vulnerabilities
54 Application GNU Gnutls 1.7.0 Version Details Vulnerabilities
55 Application GNU Gnutls 1.7.1 Version Details Vulnerabilities
56 Application GNU Gnutls 1.7.2 Version Details Vulnerabilities
57 Application GNU Gnutls 1.7.3 Version Details Vulnerabilities
58 Application GNU Gnutls 1.7.4 Version Details Vulnerabilities
59 Application GNU Gnutls 1.7.5 Version Details Vulnerabilities
60 Application GNU Gnutls 1.7.6 Version Details Vulnerabilities
61 Application GNU Gnutls 1.7.7 Version Details Vulnerabilities
62 Application GNU Gnutls 1.7.8 Version Details Vulnerabilities
63 Application GNU Gnutls 1.7.9 Version Details Vulnerabilities
64 Application GNU Gnutls 1.7.10 Version Details Vulnerabilities
65 Application GNU Gnutls 1.7.11 Version Details Vulnerabilities
66 Application GNU Gnutls 1.7.12 Version Details Vulnerabilities
67 Application GNU Gnutls 1.7.13 Version Details Vulnerabilities
68 Application GNU Gnutls 1.7.14 Version Details Vulnerabilities
69 Application GNU Gnutls 1.7.15 Version Details Vulnerabilities
70 Application GNU Gnutls 1.7.16 Version Details Vulnerabilities
71 Application GNU Gnutls 1.7.17 Version Details Vulnerabilities
72 Application GNU Gnutls 1.7.18 Version Details Vulnerabilities
73 Application GNU Gnutls 1.7.19 Version Details Vulnerabilities
74 Application GNU Gnutls 2.0.0 Version Details Vulnerabilities
75 Application GNU Gnutls 2.0.1 Version Details Vulnerabilities
76 Application GNU Gnutls 2.0.2 Version Details Vulnerabilities
77 Application GNU Gnutls 2.0.3 Version Details Vulnerabilities
78 Application GNU Gnutls 2.0.4 Version Details Vulnerabilities
79 Application GNU Gnutls 2.1.0 Version Details Vulnerabilities
80 Application GNU Gnutls 2.1.1 Version Details Vulnerabilities
81 Application GNU Gnutls 2.1.2 Version Details Vulnerabilities
82 Application GNU Gnutls 2.1.3 Version Details Vulnerabilities
83 Application GNU Gnutls 2.1.4 Version Details Vulnerabilities
84 Application GNU Gnutls 2.1.5 Version Details Vulnerabilities
85 Application GNU Gnutls 2.1.6 Version Details Vulnerabilities
86 Application GNU Gnutls 2.1.7 Version Details Vulnerabilities
87 Application GNU Gnutls 2.1.8 Version Details Vulnerabilities
88 Application GNU Gnutls 2.2.0 Version Details Vulnerabilities
89 Application GNU Gnutls 2.2.1 Version Details Vulnerabilities
90 Application GNU Gnutls 2.2.2 Version Details Vulnerabilities
91 Application GNU Gnutls 2.2.3 Version Details Vulnerabilities
92 Application GNU Gnutls 2.2.4 Version Details Vulnerabilities
93 Application GNU Gnutls 2.2.5 Version Details Vulnerabilities
94 Application GNU Gnutls 2.3.0 Version Details Vulnerabilities
95 Application GNU Gnutls 2.3.1 Version Details Vulnerabilities
96 Application GNU Gnutls 2.3.2 Version Details Vulnerabilities
97 Application GNU Gnutls 2.3.3 Version Details Vulnerabilities
98 Application GNU Gnutls 2.3.4 Version Details Vulnerabilities
99 Application GNU Gnutls 2.3.5 Version Details Vulnerabilities
100 Application GNU Gnutls 2.3.6 Version Details Vulnerabilities
101 Application GNU Gnutls 2.3.7 Version Details Vulnerabilities
102 Application GNU Gnutls 2.3.8 Version Details Vulnerabilities
103 Application GNU Gnutls 2.3.9 Version Details Vulnerabilities
104 Application GNU Gnutls 2.3.10 Version Details Vulnerabilities
105 Application GNU Gnutls 2.3.11 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
GNU Gnutls 105

- References For CVE-2008-1949

http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commitdiff;h=bc8102405fda11ea00ca3b42acc4f4bce9d6e97b CONFIRM
http://lists.gnu.org/archive/html/gnutls-devel/2008-05/msg00051.html
MLIST [gnutls-devel] 20080519 GnuTLS 2.2.4 - Security release [GNUTLS-SA-2008-1]
http://lists.gnu.org/archive/html/gnutls-devel/2008-05/msg00055.html
MLIST [gnutls-devel] 20080519 Re: GnuTLS 2.2.4 - Security release [GNUTLS-SA-2008-1]
http://secunia.com/advisories/30287
SECUNIA 30287
http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00003.html
SUSE SUSE-SA:2008:046
http://lists.gnu.org/archive/html/gnutls-devel/2008-05/msg00060.html
MLIST [gnutls-devel] 20080519 GnuTLS 2.2.5 - Brown paper bag release
http://secunia.com/advisories/30302
SECUNIA 30302
http://secunia.com/advisories/30317
SECUNIA 30317
http://secunia.com/advisories/30324
SECUNIA 30324
http://secunia.com/advisories/30330
SECUNIA 30330
http://secunia.com/advisories/30331
SECUNIA 30331
http://secunia.com/advisories/30338
SECUNIA 30338
http://secunia.com/advisories/30355
SECUNIA 30355
http://www.cert.fi/haavoittuvuudet/advisory-gnutls.html
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0174 CONFIRM
http://sourceforge.net/project/shownotes.php?release_id=600646&group_id=21558 CONFIRM
http://securityreason.com/securityalert/3902
SREASON 3902
http://security.gentoo.org/glsa/glsa-200805-20.xml
GENTOO GLSA-200805-20
http://secunia.com/advisories/31939
SECUNIA 31939
http://www.securityfocus.com/archive/1/archive/1/492282/100/0/threaded
BUGTRAQ 20080520 Vulnerability Advisory on GnuTLS
http://www.redhat.com/support/errata/RHSA-2008-0492.html
REDHAT RHSA-2008:0492
http://www.redhat.com/support/errata/RHSA-2008-0489.html
REDHAT RHSA-2008:0489
http://www.openwall.com/lists/oss-security/2008/05/20/3
MLIST [oss-security] 20080520 Re: CVE ID request: GNUTLS
http://www.openwall.com/lists/oss-security/2008/05/20/2
MLIST [oss-security] 20080520 Re: CVE ID request: GNUTLS
http://www.openwall.com/lists/oss-security/2008/05/20/1
MLIST [oss-security] 20080520 Re: CVE ID request: GNUTLS
http://www.mandriva.com/security/advisories?name=MDVSA-2008:106
MANDRIVA MDVSA-2008:106
http://www.frsirt.com/english/advisories/2008/1583/references
VUPEN ADV-2008-1583
http://www.frsirt.com/english/advisories/2008/1582/references
VUPEN ADV-2008-1582
http://www.debian.org/security/2008/dsa-1581
DEBIAN DSA-1581
http://www.securityfocus.com/archive/1/archive/1/492464/100/0/threaded
BUGTRAQ 20080522 rPSA-2008-0174-1 gnutls
http://www.ubuntu.com/usn/usn-613-1
UBUNTU USN-613-1
http://www.securitytracker.com/id?1020058
SECTRACK 1020058
https://issues.rpath.com/browse/RPL-2552 CONFIRM
http://xforce.iss.net/xforce/xfdb/42530
XF gnutls-gnutlsrecvclientkxmessage-bo(42530)
https://www.redhat.com/archives/fedora-package-announce/2008-May/msg00487.html
FEDORA FEDORA-2008-4183
https://www.redhat.com/archives/fedora-package-announce/2008-May/msg00590.html
FEDORA FEDORA-2008-4259
https://www.redhat.com/archives/fedora-package-announce/2008-May/msg00615.html
FEDORA FEDORA-2008-4274
http://www.securityfocus.com/bid/29292
BID 29292 GnuTLS Prior to 2.2.5 Multiple Remote Vulnerabilities Release Date:2008-09-17
http://www.kb.cert.org/vuls/id/252626
CERT-VN VU#252626

- Metasploit Modules Related To CVE-2008-1949

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.