CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-5000

Cross-site scripting (XSS) vulnerability in the (1) mod_imap module in the Apache HTTP Server 1.3.0 through 1.3.39 and 2.0.35 through 2.0.61 and the (2) mod_imagemap module in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Publish Date : 2007-12-13 Last Update Date : 2013-08-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID 79

- Vendor Statements

Fixed in Apache HTTP Server 2.2.8, 2.0.63, and 1.3.41: http://httpd.apache.org/security/vulnerabilities_22.html http://httpd.apache.org/security/vulnerabilities_20.html http://httpd.apache.org/security/vulnerabilities_13.html
Source: Apache

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2007-12-11 2007-12-11
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Cross-site scripting (XSS) vulnerability in the (1) mod_imap module in the Apache HTTP Server 1.3.0 through 1.3.39 and 2... oval:org.mitre.oval:def:9539 unix
CVE-2007-5000 oval:org.opensuse.security:def:20075000 unix
ELSA-2008:0008: httpd security update (Moderate) oval:org.mitre.oval:def:22498 unix
mod_imagemap XSS oval:org.apache.httpd:def:20075000
RHSA-2008:0005: httpd security update (Moderate) oval:com.redhat.rhsa:def:20080005 unix
RHSA-2008:0006: httpd security update (Moderate) oval:com.redhat.rhsa:def:20080006 unix
RHSA-2008:0008: httpd security update (Moderate) oval:com.redhat.rhsa:def:20080008 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-5000

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Http Server 1.3.0 Version Details Vulnerabilities
2 Application Apache Http Server 1.3.1 Version Details Vulnerabilities
3 Application Apache Http Server 1.3.4 Version Details Vulnerabilities
4 Application Apache Http Server 1.3.5 Version Details Vulnerabilities
5 Application Apache Http Server 1.3.6 Version Details Vulnerabilities
6 Application Apache Http Server 1.3.7 Version Details Vulnerabilities
7 Application Apache Http Server 1.3.8 Version Details Vulnerabilities
8 Application Apache Http Server 1.3.9 Version Details Vulnerabilities
9 Application Apache Http Server 1.3.11 Version Details Vulnerabilities
10 Application Apache Http Server 1.3.12 Version Details Vulnerabilities
11 Application Apache Http Server 1.3.22 Version Details Vulnerabilities
12 Application Apache Http Server 1.3.23 Version Details Vulnerabilities
13 Application Apache Http Server 1.3.24 Version Details Vulnerabilities
14 Application Apache Http Server 1.3.25 Version Details Vulnerabilities
15 Application Apache Http Server 1.3.26 Version Details Vulnerabilities
16 Application Apache Http Server 1.3.27 Version Details Vulnerabilities
17 Application Apache Http Server 1.3.28 Version Details Vulnerabilities
18 Application Apache Http Server 1.3.29 Version Details Vulnerabilities
19 Application Apache Http Server 1.3.30 Version Details Vulnerabilities
20 Application Apache Http Server 1.3.31 Version Details Vulnerabilities
21 Application Apache Http Server 1.3.32 Version Details Vulnerabilities
22 Application Apache Http Server 1.3.33 Version Details Vulnerabilities
23 Application Apache Http Server 1.3.37 Version Details Vulnerabilities
24 Application Apache Http Server 2.0.35 Version Details Vulnerabilities
25 Application Apache Http Server 2.0.36 Version Details Vulnerabilities
26 Application Apache Http Server 2.0.37 Version Details Vulnerabilities
27 Application Apache Http Server 2.0.38 Version Details Vulnerabilities
28 Application Apache Http Server 2.0.39 Version Details Vulnerabilities
29 Application Apache Http Server 2.0.40 Version Details Vulnerabilities
30 Application Apache Http Server 2.0.41 Version Details Vulnerabilities
31 Application Apache Http Server 2.0.42 Version Details Vulnerabilities
32 Application Apache Http Server 2.0.43 Version Details Vulnerabilities
33 Application Apache Http Server 2.0.44 Version Details Vulnerabilities
34 Application Apache Http Server 2.0.45 Version Details Vulnerabilities
35 Application Apache Http Server 2.0.46 Version Details Vulnerabilities
36 Application Apache Http Server 2.0.47 Version Details Vulnerabilities
37 Application Apache Http Server 2.0.48 Version Details Vulnerabilities
38 Application Apache Http Server 2.0.49 Version Details Vulnerabilities
39 Application Apache Http Server 2.0.50 Version Details Vulnerabilities
40 Application Apache Http Server 2.0.51 Version Details Vulnerabilities
41 Application Apache Http Server 2.0.52 Version Details Vulnerabilities
42 Application Apache Http Server 2.0.53 Version Details Vulnerabilities
43 Application Apache Http Server 2.0.54 Version Details Vulnerabilities
44 Application Apache Http Server 2.0.55 Version Details Vulnerabilities
45 Application Apache Http Server 2.0.56 Version Details Vulnerabilities
46 Application Apache Http Server 2.0.57 Version Details Vulnerabilities
47 Application Apache Http Server 2.0.58 Version Details Vulnerabilities
48 Application Apache Http Server 2.0.59 Version Details Vulnerabilities
49 Application Apache Http Server 2.0.60 Version Details Vulnerabilities
50 Application Apache Http Server 2.0.61 Version Details Vulnerabilities
51 Application Apache Http Server 2.2 Version Details Vulnerabilities
52 Application Apache Http Server 2.2.1 Version Details Vulnerabilities
53 Application Apache Http Server 2.2.2 Version Details Vulnerabilities
54 Application Apache Http Server 2.2.3 Version Details Vulnerabilities
55 Application Apache Http Server 2.2.4 Version Details Vulnerabilities
56 Application Apache Http Server 2.2.5 Version Details Vulnerabilities
57 Application Apache Http Server 2.2.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Http Server 57

- References For CVE-2007-5000

http://secunia.com/advisories/28977
SECUNIA 28977
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00562.html
FEDORA FEDORA-2008-1695
http://lists.apple.com/archives/security-announce/2008//May/msg00001.html
APPLE APPLE-SA-2008-05-28
http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html
APPLE APPLE-SA-2008-03-18
http://lists.opensuse.org/opensuse-security-announce/2008-04/msg00004.html
SUSE SUSE-SA:2008:021
http://secunia.com/advisories/28081
SECUNIA 28081
http://secunia.com/advisories/28196
SECUNIA 28196
http://secunia.com/advisories/28375
SECUNIA 28375
http://secunia.com/advisories/28467
SECUNIA 28467
http://secunia.com/advisories/28471
SECUNIA 28471
http://secunia.com/advisories/28525
SECUNIA 28525
http://secunia.com/advisories/28526
SECUNIA 28526
http://secunia.com/advisories/28607
SECUNIA 28607
http://secunia.com/advisories/28749
SECUNIA 28749
http://secunia.com/advisories/28750
SECUNIA 28750
http://secunia.com/advisories/28922
SECUNIA 28922
http://secunia.com/advisories/29420
SECUNIA 29420
http://secunia.com/advisories/29988
SECUNIA 29988
http://secunia.com/advisories/29806
SECUNIA 29806
http://secunia.com/advisories/29640
SECUNIA 29640
http://secunia.com/advisories/30356
SECUNIA 30356
http://secunia.com/advisories/30430
SECUNIA 30430
http://securitytracker.com/id?1019093
SECTRACK 1019093
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.595748
SLACKWARE SSA:2008-045-02
http://sunsolve.sun.com/search/document.do?assetkey=1-26-233623-1
SUNALERT 233623
http://support.avaya.com/elmodocs2/security/ASA-2008-032.htm CONFIRM
http://www-1.ibm.com/support/docview.wss?uid=swg1PK63273
AIXAPAR PK63273
http://www-1.ibm.com/support/docview.wss?uid=swg1PK58074
AIXAPAR PK58074
http://www-1.ibm.com/support/docview.wss?uid=swg24019245
AIXAPAR PK65782
http://www-1.ibm.com/support/docview.wss?uid=swg1PK58024
AIXAPAR PK58024
http://www.osvdb.org/39134
OSVDB 39134
http://www.mandriva.com/security/advisories?name=MDVSA-2008:016
MANDRIVA MDVSA-2008:016
http://www.mandriva.com/security/advisories?name=MDVSA-2008:015
MANDRIVA MDVSA-2008:015
http://www.mandriva.com/security/advisories?name=MDVSA-2008:014
MANDRIVA MDVSA-2008:014
http://www.fujitsu.com/global/support/software/security/products-f/interstage-200801e.html CONFIRM
http://www.redhat.com/support/errata/RHSA-2008-0006.html
REDHAT RHSA-2008:0006
http://www.redhat.com/support/errata/RHSA-2008-0004.html
REDHAT RHSA-2008:0004
http://www.redhat.com/support/errata/RHSA-2008-0005.html
REDHAT RHSA-2008:0005
http://www.redhat.com/support/errata/RHSA-2008-0007.html
REDHAT RHSA-2008:0007
http://www.redhat.com/support/errata/RHSA-2008-0008.html
REDHAT RHSA-2008:0008
http://www.ubuntu.com/usn/usn-575-1
UBUNTU USN-575-1
http://www.securityfocus.com/bid/26838
BID 26838 Apache mod_imagemap and mod_imap Cross-Site Scripting Vulnerability Release Date:2013-07-16
http://www.redhat.com/support/errata/RHSA-2008-0261.html
REDHAT RHSA-2008:0261
http://www.redhat.com/support/errata/RHSA-2008-0009.html
REDHAT RHSA-2008:0009
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01345501
HP SSRT080010
http://www.vupen.com/english/advisories/2008/0809/references
VUPEN ADV-2008-0809
http://www.vupen.com/english/advisories/2008/0398
VUPEN ADV-2008-0398
http://www.vupen.com/english/advisories/2008/0178
VUPEN ADV-2008-0178
http://www.vupen.com/english/advisories/2008/0084
VUPEN ADV-2008-0084
http://www.vupen.com/english/advisories/2007/4301
VUPEN ADV-2007-4301
http://www.vupen.com/english/advisories/2007/4202
VUPEN ADV-2007-4202
http://www.vupen.com/english/advisories/2007/4201
VUPEN ADV-2007-4201
http://www.securityfocus.com/archive/1/archive/1/505990/100/0/threaded
BUGTRAQ 20090821 VMSA-2009-0010 VMware Hosted products update libpng and Apache HTTP Server
http://www.securityfocus.com/archive/1/archive/1/498523/100/0/threaded
HP SSRT080059
http://www.securityfocus.com/archive/1/archive/1/494428/100/0/threaded
BUGTRAQ 20080716 rPSA-2008-0035-1 httpd mod_ssl
http://www.oracle.com/technetwork/topics/security/cpujuly2013-1899826.html CONFIRM
http://www.vupen.com/english/advisories/2008/1623/references
VUPEN ADV-2008-1623
http://docs.info.apple.com/article.html?artnum=307562 CONFIRM
http://marc.info/?l=bugtraq&m=130497311408250&w=2
HP HPSBOV02683
http://lists.vmware.com/pipermail/security-announce/2009/000062.html
MLIST [security-announce] 20090820 VMSA-2009-0010 VMware Hosted products update libpng and Apache HTTP Server
http://httpd.apache.org/security/vulnerabilities_22.html CONFIRM
http://httpd.apache.org/security/vulnerabilities_20.html CONFIRM
http://httpd.apache.org/security/vulnerabilities_13.html CONFIRM
http://secunia.com/advisories/32800
SECUNIA 32800
http://secunia.com/advisories/31142
SECUNIA 31142
http://secunia.com/advisories/30732
SECUNIA 30732
http://secunia.com/advisories/28046
SECUNIA 28046
http://secunia.com/advisories/28073
SECUNIA 28073
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00541.html
FEDORA FEDORA-2008-1711
http://www.us-cert.gov/cas/techalerts/TA08-150A.html
CERT TA08-150A
http://www.vupen.com/english/advisories/2008/1875/references
VUPEN ADV-2008-1875
http://www.vupen.com/english/advisories/2008/1697
VUPEN ADV-2008-1697
http://www.vupen.com/english/advisories/2008/0924/references
VUPEN ADV-2008-0924
http://www.vupen.com/english/advisories/2008/1224/references
VUPEN ADV-2008-1224

- Metasploit Modules Related To CVE-2007-5000

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.