CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-1999-0440

The byte code verifier component of the Java Virtual Machine (JVM) allows remote execution through malicious web pages.
Publish Date : 1999-03-01 Last Update Date : 2008-09-09
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute Code
CWE ID CWE id is not defined for this vulnerability

- Products Affected By CVE-1999-0440

# Product Type Vendor Product Version Update Edition Language
1 Application Netscape Communicator 4.5 Version Details Vulnerabilities
2 Application Netscape Navigator 4.0 Version Details Vulnerabilities
3 Application Netscape Navigator 4.01 Version Details Vulnerabilities
4 Application Netscape Navigator 4.02 Version Details Vulnerabilities
5 Application Netscape Navigator 4.03 Version Details Vulnerabilities
6 Application Netscape Navigator 4.04 Version Details Vulnerabilities
7 Application Netscape Navigator 4.05 Version Details Vulnerabilities
8 Application Netscape Navigator 4.5 Version Details Vulnerabilities
9 Application Netscape Navigator 4.06 Version Details Vulnerabilities
10 Application Netscape Navigator 4.07 Version Details Vulnerabilities
11 Application Netscape Navigator 4.08 Version Details Vulnerabilities
12 Application Netscape Navigator 4.61 Version Details Vulnerabilities
13 Application SUN Java Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Netscape Communicator 1
Netscape Navigator 11
SUN Java 1

- References For CVE-1999-0440

http://marc.theaimsgroup.com/?l=bugtraq&m=92333596624452&w=2
BUGTRAQ 19990405 Security Hole in Java 2 (and JDK 1.1.x)
http://www.securityfocus.com/bid/1939
BID 1939 Multiple Vendor Java Virtual Machine Type Confusion Attack Vulnerability Release Date:1999-04-05
http://java.sun.com/pr/1999/03/pr990329-01.html CONFIRM

- Metasploit Modules Related To CVE-1999-0440

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.