CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-2122 (1 public exploit)

sql/password.c in Oracle MySQL 5.1.x before 5.1.63, 5.5.x before 5.5.24, and 5.6.x before 5.6.6, and MariaDB 5.1.x before 5.1.62, 5.2.x before 5.2.12, 5.3.x before 5.3.6, and 5.5.x before 5.5.23, when running in certain environments with certain implementations of the memcmp function, allows remote attackers to bypass authentication by repeatedly authenticating with the same incorrect password, which eventually causes a token comparison to succeed due to an improperly-checked return value.
Publish Date : 2012-06-26 Last Update Date : 2014-02-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Bypass a restriction or similar
CWE ID 287

- Related OVAL Definitions

Title Definition Id Class Family
DSA-2496-1 mysql-5.1 - several oval:org.mitre.oval:def:19860 unix
USN-1467-1 -- mysql-5.1, mysql-5.5, mysql-dfsg-5.0, mysql-dfsg-5.1 vulnerabilities oval:org.mitre.oval:def:17885 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2012-2122

# Product Type Vendor Product Version Update Edition Language
1 Application Mariadb Mariadb 5.1.41 Version Details Vulnerabilities
2 Application Mariadb Mariadb 5.1.42 Version Details Vulnerabilities
3 Application Mariadb Mariadb 5.1.44 Version Details Vulnerabilities
4 Application Mariadb Mariadb 5.1.47 Version Details Vulnerabilities
5 Application Mariadb Mariadb 5.1.49 Version Details Vulnerabilities
6 Application Mariadb Mariadb 5.1.50 Version Details Vulnerabilities
7 Application Mariadb Mariadb 5.1.51 Version Details Vulnerabilities
8 Application Mariadb Mariadb 5.1.53 Version Details Vulnerabilities
9 Application Mariadb Mariadb 5.1.55 Version Details Vulnerabilities
10 Application Mariadb Mariadb 5.1.60 Version Details Vulnerabilities
11 Application Mariadb Mariadb 5.1.61 Version Details Vulnerabilities
12 Application Mariadb Mariadb 5.2.0 Version Details Vulnerabilities
13 Application Mariadb Mariadb 5.2.1 Version Details Vulnerabilities
14 Application Mariadb Mariadb 5.2.2 Version Details Vulnerabilities
15 Application Mariadb Mariadb 5.2.3 Version Details Vulnerabilities
16 Application Mariadb Mariadb 5.2.4 Version Details Vulnerabilities
17 Application Mariadb Mariadb 5.2.5 Version Details Vulnerabilities
18 Application Mariadb Mariadb 5.2.6 Version Details Vulnerabilities
19 Application Mariadb Mariadb 5.2.7 Version Details Vulnerabilities
20 Application Mariadb Mariadb 5.2.8 Version Details Vulnerabilities
21 Application Mariadb Mariadb 5.2.9 Version Details Vulnerabilities
22 Application Mariadb Mariadb 5.2.10 Version Details Vulnerabilities
23 Application Mariadb Mariadb 5.2.11 Version Details Vulnerabilities
24 Application Mariadb Mariadb 5.3.0 Version Details Vulnerabilities
25 Application Mariadb Mariadb 5.3.1 Version Details Vulnerabilities
26 Application Mariadb Mariadb 5.3.2 Version Details Vulnerabilities
27 Application Mariadb Mariadb 5.3.3 Version Details Vulnerabilities
28 Application Mariadb Mariadb 5.3.4 Version Details Vulnerabilities
29 Application Mariadb Mariadb 5.3.5 Version Details Vulnerabilities
30 Application Mariadb Mariadb 5.3.6 Version Details Vulnerabilities
31 Application Mariadb Mariadb 5.5.20 Version Details Vulnerabilities
32 Application Mariadb Mariadb 5.5.21 Version Details Vulnerabilities
33 Application Mariadb Mariadb 5.5.22 Version Details Vulnerabilities
34 Application Oracle Mysql 5.1.51 Version Details Vulnerabilities
35 Application Oracle Mysql 5.1.52 Version Details Vulnerabilities
36 Application Oracle Mysql 5.1.52 SP1 Version Details Vulnerabilities
37 Application Oracle Mysql 5.1.53 Version Details Vulnerabilities
38 Application Oracle Mysql 5.1.54 Version Details Vulnerabilities
39 Application Oracle Mysql 5.1.55 Version Details Vulnerabilities
40 Application Oracle Mysql 5.1.56 Version Details Vulnerabilities
41 Application Oracle Mysql 5.1.57 Version Details Vulnerabilities
42 Application Oracle Mysql 5.1.58 Version Details Vulnerabilities
43 Application Oracle Mysql 5.1.59 Version Details Vulnerabilities
44 Application Oracle Mysql 5.1.60 Version Details Vulnerabilities
45 Application Oracle Mysql 5.1.61 Version Details Vulnerabilities
46 Application Oracle Mysql 5.5.10 Version Details Vulnerabilities
47 Application Oracle Mysql 5.5.11 Version Details Vulnerabilities
48 Application Oracle Mysql 5.5.12 Version Details Vulnerabilities
49 Application Oracle Mysql 5.5.13 Version Details Vulnerabilities
50 Application Oracle Mysql 5.5.14 Version Details Vulnerabilities
51 Application Oracle Mysql 5.5.15 Version Details Vulnerabilities
52 Application Oracle Mysql 5.5.16 Version Details Vulnerabilities
53 Application Oracle Mysql 5.5.17 Version Details Vulnerabilities
54 Application Oracle Mysql 5.5.18 Version Details Vulnerabilities
55 Application Oracle Mysql 5.5.19 Version Details Vulnerabilities
56 Application Oracle Mysql 5.5.20 Version Details Vulnerabilities
57 Application Oracle Mysql 5.5.21 Version Details Vulnerabilities
58 Application Oracle Mysql 5.6.2 Version Details Vulnerabilities
59 Application Oracle Mysql 5.6.3 Version Details Vulnerabilities
60 Application Oracle Mysql 5.6.4 Version Details Vulnerabilities
61 Application Oracle Mysql 5.6.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mariadb Mariadb 33
Oracle Mysql 28

- References For CVE-2012-2122

http://bugs.mysql.com/bug.php?id=64884
http://seclists.org/oss-sec/2012/q2/493
MLIST [oss-security] 20120609 Security vulnerability in MySQL/MariaDB sql/password.c
http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00007.html
SUSE SUSE-SU-2012:0984
http://security.gentoo.org/glsa/glsa-201308-06.xml
GENTOO GLSA-201308-06
http://kb.askmonty.org/en/mariadb-5162-release-notes/ CONFIRM
http://secunia.com/advisories/53372
SECUNIA 53372
http://securitytracker.com/id?1027143
SECTRACK 1027143
https://community.rapid7.com/community/metasploit/blog/2012/06/11/cve-2012-2122-a-tragically-comedic-security-flaw-in-mysql
http://secunia.com/advisories/49417
SECUNIA 49417
http://www.securityfocus.com/bid/53911
BID 53911 Oracle MySQL CVE-2012-2122 User Login Security Bypass Vulnerability Release Date:2013-09-02
Exploit! http://www.exploit-db.com/exploits/19092
EXPLOIT-DB 19092 MySQL Remote Root Authentication Bypass Author:David Kennedy (ReL1K) Release Date:2012-06-12 (multiple) remote

- Metasploit Modules Related To CVE-2012-2122

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.