CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-4344 (1 public exploit)

Heap-based buffer overflow in the string_vformat function in string.c in Exim before 4.70 allows remote attackers to execute arbitrary code via an SMTP session that includes two MAIL commands in conjunction with a large message containing crafted headers, leading to improper rejection logging.
Publish Date : 2010-12-14 Last Update Date : 2011-01-12
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
7.5
AV:N/AC:L/Au:N/C:P/I:P/A:P 2010-12-09 2010-12-07
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2010-4344 oval:org.opensuse.security:def:20104344 unix
DSA-2131-1 exim4 -- arbitrary code execution oval:org.mitre.oval:def:12720 unix
ELSA-2010:0970: exim security update (Critical) oval:org.mitre.oval:def:23061 unix
RHSA-2010:0970: exim security update (Critical) oval:com.redhat.rhsa:def:20100970 unix
RHSA-2010:0970: exim security update (Critical) oval:org.mitre.oval:def:22059 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-4344

# Product Type Vendor Product Version Update Edition Language
1 Application Exim Exim 2.10 Version Details Vulnerabilities
2 Application Exim Exim 2.11 Version Details Vulnerabilities
3 Application Exim Exim 2.12 Version Details Vulnerabilities
4 Application Exim Exim 3.00 Version Details Vulnerabilities
5 Application Exim Exim 3.01 Version Details Vulnerabilities
6 Application Exim Exim 3.02 Version Details Vulnerabilities
7 Application Exim Exim 3.03 Version Details Vulnerabilities
8 Application Exim Exim 3.10 Version Details Vulnerabilities
9 Application Exim Exim 3.11 Version Details Vulnerabilities
10 Application Exim Exim 3.12 Version Details Vulnerabilities
11 Application Exim Exim 3.13 Version Details Vulnerabilities
12 Application Exim Exim 3.14 Version Details Vulnerabilities
13 Application Exim Exim 3.15 Version Details Vulnerabilities
14 Application Exim Exim 3.16 Version Details Vulnerabilities
15 Application Exim Exim 3.20 Version Details Vulnerabilities
16 Application Exim Exim 3.21 Version Details Vulnerabilities
17 Application Exim Exim 3.22 Version Details Vulnerabilities
18 Application Exim Exim 3.30 Version Details Vulnerabilities
19 Application Exim Exim 3.31 Version Details Vulnerabilities
20 Application Exim Exim 3.32 Version Details Vulnerabilities
21 Application Exim Exim 3.33 Version Details Vulnerabilities
22 Application Exim Exim 3.34 Version Details Vulnerabilities
23 Application Exim Exim 3.35 Version Details Vulnerabilities
24 Application Exim Exim 3.36 Version Details Vulnerabilities
25 Application Exim Exim 4.00 Version Details Vulnerabilities
26 Application Exim Exim 4.01 Version Details Vulnerabilities
27 Application Exim Exim 4.02 Version Details Vulnerabilities
28 Application Exim Exim 4.03 Version Details Vulnerabilities
29 Application Exim Exim 4.04 Version Details Vulnerabilities
30 Application Exim Exim 4.05 Version Details Vulnerabilities
31 Application Exim Exim 4.10 Version Details Vulnerabilities
32 Application Exim Exim 4.11 Version Details Vulnerabilities
33 Application Exim Exim 4.12 Version Details Vulnerabilities
34 Application Exim Exim 4.14 Version Details Vulnerabilities
35 Application Exim Exim 4.20 Version Details Vulnerabilities
36 Application Exim Exim 4.21 Version Details Vulnerabilities
37 Application Exim Exim 4.22 Version Details Vulnerabilities
38 Application Exim Exim 4.23 Version Details Vulnerabilities
39 Application Exim Exim 4.24 Version Details Vulnerabilities
40 Application Exim Exim 4.30 Version Details Vulnerabilities
41 Application Exim Exim 4.31 Version Details Vulnerabilities
42 Application Exim Exim 4.32 Version Details Vulnerabilities
43 Application Exim Exim 4.33 Version Details Vulnerabilities
44 Application Exim Exim 4.34 Version Details Vulnerabilities
45 Application Exim Exim 4.40 Version Details Vulnerabilities
46 Application Exim Exim 4.41 Version Details Vulnerabilities
47 Application Exim Exim 4.42 Version Details Vulnerabilities
48 Application Exim Exim 4.43 Version Details Vulnerabilities
49 Application Exim Exim 4.44 Version Details Vulnerabilities
50 Application Exim Exim 4.50 Version Details Vulnerabilities
51 Application Exim Exim 4.51 Version Details Vulnerabilities
52 Application Exim Exim 4.52 Version Details Vulnerabilities
53 Application Exim Exim 4.53 Version Details Vulnerabilities
54 Application Exim Exim 4.54 Version Details Vulnerabilities
55 Application Exim Exim 4.60 Version Details Vulnerabilities
56 Application Exim Exim 4.61 Version Details Vulnerabilities
57 Application Exim Exim 4.62 Version Details Vulnerabilities
58 Application Exim Exim 4.63 Version Details Vulnerabilities
59 Application Exim Exim 4.64 Version Details Vulnerabilities
60 Application Exim Exim 4.65 Version Details Vulnerabilities
61 Application Exim Exim 4.66 Version Details Vulnerabilities
62 Application Exim Exim 4.67 Version Details Vulnerabilities
63 Application Exim Exim 4.68 Version Details Vulnerabilities
64 Application Exim Exim 4.69 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Exim Exim 64

- References For CVE-2010-4344

http://atmail.com/blog/2010/atmail-6204-now-available/ CONFIRM
http://www.securityfocus.com/bid/45308
BID 45308 Exim Crafted Header Remote Code Execution Vulnerability Release Date:2011-09-15
http://www.kb.cert.org/vuls/id/682457
CERT-VN VU#682457
ftp://ftp.exim.org/pub/exim/ChangeLogs/ChangeLog-4.70 CONFIRM
http://www.osvdb.org/69685
OSVDB 69685
http://openwall.com/lists/oss-security/2010/12/10/1
MLIST [oss-security] 20101210 Exim remote root
http://secunia.com/advisories/40019
SECUNIA 40019
http://secunia.com/advisories/42576
SECUNIA 42576
http://secunia.com/advisories/42586
SECUNIA 42586
http://secunia.com/advisories/42589
SECUNIA 42589
http://secunia.com/advisories/42587
SECUNIA 42587
http://www.cpanel.net/2010/12/exim-remote-memory-corruption-vulnerability-notification-cve-2010-4344.html CONFIRM
http://www.exim.org/lurker/message/20101207.215955.bb32d4f2.en.html
MLIST [exim-dev] 20101207 Remote root vulnerability in Exim
http://www.debian.org/security/2010/dsa-2131
DEBIAN DSA-2131
Exploit! http://www.metasploit.com/modules/exploit/unix/smtp/exim4_string_format
http://www.redhat.com/support/errata/RHSA-2010-0970.html
REDHAT RHSA-2010:0970
http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00003.html
SUSE SUSE-SA:2010:059
http://www.securityfocus.com/archive/1/archive/1/515172/100/0/threaded
BUGTRAQ 20101213 Exim security issue in historical release
http://www.theregister.co.uk/2010/12/11/exim_code_execution_peril/
http://www.ubuntu.com/usn/USN-1032-1
UBUNTU USN-1032-1
http://www.vupen.com/english/advisories/2010/3171
VUPEN ADV-2010-3171
http://www.vupen.com/english/advisories/2010/3172
VUPEN ADV-2010-3172
http://www.vupen.com/english/advisories/2010/3181
VUPEN ADV-2010-3181
http://www.vupen.com/english/advisories/2010/3186
VUPEN ADV-2010-3186
http://www.vupen.com/english/advisories/2010/3204
VUPEN ADV-2010-3204
http://www.vupen.com/english/advisories/2010/3246
VUPEN ADV-2010-3246
http://www.vupen.com/english/advisories/2010/3317
VUPEN ADV-2010-3317
https://bugzilla.redhat.com/show_bug.cgi?id=661756 CONFIRM
http://bugs.exim.org/show_bug.cgi?id=787 CONFIRM
http://www.securitytracker.com/id?1024858
SECTRACK 1024858
http://git.exim.org/exim.git/commit/24c929a27415c7cfc7126c47e4cad39acf3efa6b CONFIRM
http://lists.exim.org/lurker/message/20101210.164935.385e04d0.en.html
MLIST [exim-dev] 20101210 Re: Remote root vulnerability in Exim

- Metasploit Modules Related To CVE-2010-4344

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.